IDLE WARNING: The version of Tcl/Tk (8.5.9) in use may be unstable

If you install the latest release of Python for Mac OS X 64-bit/32-bit and run IDLE, you may get an error like this one:

>>> WARNING: The version of Tcl/Tk (8.5.9) in use may be unstable. Visit http://www.python.org/download/mac/tcltk/ for current information.

Visit https://www.python.org/download/mac/tcltk/ and you’ll see:

IDLE-tcltkClick on the Install link, which takes you to a page with these options:

download-tclThis is where I went wrong initially. I downloaded and installed the 8.6 version, but I still got the error. Jason Briggs explains why here. Apparently, IDLE is looking for the latest 8.5 version, so the one to download is the one I circled above.

Related Training: Python

About Webucator

Webucator provides instructor-led training to students throughout the US and Canada. We have trained over 90,000 students from over 16,000 organizations on technologies such as Microsoft ASP.NET, Microsoft Office, Azure, Windows, Java, Adobe, Python, SQL, JavaScript, Angular and much more. Check out our complete course catalog.